Clean PHP 5.2.12 Build Core Dumping

Don O'Neil lists at
Sun Jan 10 21:00:41 UTC 2010

> > I tried adding WITHOUT_X11=yes to /etc/make.conf as well as X11BASE=
> and
> > X11BASE="", but I still get the same error.
> Remove them. This makes sure they are not defined, not even
> empty (as in "#define BLA -> symbol 'BLA' is defined").
> > Where to go from here? Do I have and old version of something that is
> > causing this? I get this error _right away_ before anything is even
> built.
> It seems to be a check by the Makefile at port's top level.

Ok... I have no definition for X11BASE anywhere, not in my env, not in my
/etc/make.conf, nowhwere...

However, it's still complaining about X11BASE being deprecated. I tried just
adding WITHOUT_X11=yes in /etc/make, and without it. I even searched all the
Makefiles in /usr/ports, and in the /usr/ports/lang/php5 dir to find any
reference to X11, or X, or X11BASE, but nada... I don't even know where this
error message is being generated from.

I can't even do a basic make without it immediately spitting out the error:

# make
X11BASE is now deprecated.  Unset X11BASE in make.conf and try again.
*** Error code 1


Where should I look next? Any help is appreciated. Thanks!

More information about the freebsd-questions mailing list