port-MESS with apache22

PJ af.gourmet at videotron.ca
Sat Jan 9 15:57:26 UTC 2010

Thanks for the response, Matthew.

Now that I've had somewhat of a night's sleep thinking about the
problem. This might help clear things for future generations. :-)

Here's some background: Before upgrading from 7.2 RELEASE to 8.0 RELEASE
, I had run portsnap on 7.2 but did not update the ports.
Is it possible that this may be the source of the problem?
PWould it make sense to rebuild the ports database and portsnap now that
I'm running 8.0 and then reinstalling either just the problem apps or
maybe do another complete reinstall (# portupgrade -af - -batch). It's a
PITA but if that fixes things...
I seem to recall that there are probably differences in the ports for
different os versions?
I do recall that when I was updating apache, I did make config and
erroneously checked proxy_lconnect SSL support (do not use proxy). This
generated a stop in the install and somewhere at this point I noticed
that there had been an apache2 directory created. I tried to find the
problem but figured that once installed, a deinstall and reinstall would
fix thinkg. I think I mucked up something as I had to delete all the
files and work directories in the hope they would be regenrated when
installing. Well, no such luck. However, I have backups of all
installations on another disk and was able to copy the files directory
to the port. Anyway, the installation went all the way and on reboot
apache was working. But when I tried to access my virtual sites, things
were not quite right.
Thanks again.

On 1/9/2010 4:34 AM, Matthew Seaman wrote:
> PJ wrote:
>> Upgraded to 8.0 without problem.
>> Reinstalling ports was tedious... but NP for most part.
>> Sommehow the installation of apache22 stumbled over some configuration
>> issues, I think....
>> I found that apache was running ok, except...
>> php5 module was not correctly installed...
> mod_php5 isn't built by default when you install php5.  This catches
> out a very large number of people, and it is particularly astonishing
> as integrating php into apache is probably the number one reason for
> installing php.
> Sounds like you may need to do this:
>    # cd /usr/ports/lang/php5
>    # make config
>    [ Make sure the option for 'Build Apache Module' is checked ]
>    # portupgrade -f lang/php5
>      -or-
>    # portmaster --force-config -f lang/php5
> It might also be necessary to rebuild all of the php5 modules -- plus
> any pecl- modules.  At the cost of reinstalling pear- modules and PHP
> apps (which should be fairly cheap, as the port installation process for
> that sort of port consists almost entirely of copying files into place)
> you can just do this:
>    # portupgrade -fr lang/php5
>    -or-
>    # portmaster -fr lang/php5
> Also double check httpd.conf once PHP5 is installed with mod_php5 --
> the port will automatically add a line to
> ${PREFIX}/etc/apache22/httpd.conf
> to cause apache to load the module, which should look like this:
> LoadModule php5_module        libexec/apache22/libphp5.so
> As I recall, PHP5 creates that line as shown, which should work straight
> away, but some modules add a commented out LoadModule line, so it would
> be a good idea to eliminate that as a potential problem.
>     Cheers,
>     Matthew

More information about the freebsd-questions mailing list