Printing via USB Port

Warren Block wblock at
Sat Feb 27 02:10:32 UTC 2010

On Fri, 26 Feb 2010, Bill Tillman wrote:

> I found many drivers for the HL-12xx models. I have used this in my 
> previous setup with my old parallel server. I actually tried what you 
> suggested and it only worked when using the parallel cable, not the 
> USB. For some reason the USB connection on this and any other FreeBSD 
> server I connect to is DOA for printing. I run mouse and keyboard via 
> USB. But these print jobs are lining up in the queue and just sit 
> there no matter how many times I reconnect the printer, or reboot it 
> or reboot the computer. And once again I'm seeing two instances of lpd 
> running when I only launched it from the command line once, no entry 
> in /etc/rc.conf.
> BigDell# ps -ax | grep lpd
>  1311  ??  Is     0:00.00 lpd
>  1329  ??  IE     0:00.00 lpd

One is the daemon, the other is the spawned job trying to send the print 
jobs and exit.

Found one more thing:
Try using the unlpt0 device.

-Warren Block * Rapid City, South Dakota USA

More information about the freebsd-questions mailing list