Printing via USB Port

Bill Tillman btillman99 at
Sat Feb 27 00:19:42 UTC 2010

--- On Fri, 2/26/10, Warren Block <wblock at> wrote:

From: Warren Block <wblock at>
Subject: Re: Printing via USB Port
To: "Bill Tillman" <btillman99 at>
Cc: freebsd-questions at
Date: Friday, February 26, 2010, 5:38 PM

On Fri, 26 Feb 2010, Bill Tillman wrote:
> Thanks again for your valuable input. I have set up lpd printing on my old FreeBSD server at least a dozen times and it became a simple routine to do with apsfilter. Let me see if I can place all my cards in one place and perhaps we can find the bug.

I think I found it.  The HL-2040 is a GDI printer, aka winprinter (aka "oh no, one of those", aka "I guess I didn't really want to print that after all").  It won't respond to PCL, unlike the one I looked up first, the HL-2060.

Based on

  % cd /usr/local/libexec
  % cp ps2pcl ps2hl1250

Change the line in ps2hl1250 to:

/usr/local/bin/gs -dSAFER -dNOPAUSE -q -sDEVICE=hl1250 -sOutputFile=- -
And change the if= line in the printcap to refer to ps2hl1250.

(And remember, buying winprinters just encourages them to make more.)

-Warren Block * Rapid City, South Dakota USA
Once again many thanks, but that is one of the first things I tried. By checking ghostcript's drivers
#gs -h | grep hl
I found many drivers for the HL-12xx models. I have used this in my previous setup with my old parallel server. I actually tried what you suggested and it only worked when using the parallel cable, not the USB. For some reason the USB connection on this and any other FreeBSD server I connect to is DOA for printing. I run mouse and keyboard via USB. But these print jobs are lining up in the queue and just sit there no matter how many times I reconnect the printer, or reboot it or reboot the computer. And once again I'm seeing two instances of lpd running when I only launched it from the command line once, no entry in /etc/rc.conf.
BigDell# ps -ax | grep lpd
 1311  ??  Is     0:00.00 lpd
 1329  ??  IE     0:00.00 lpd

BigDell# lpq
no entries

BigDell# lpc status all
        queuing is enabled
        printing is enabled
        no entries in spool area
        printer idle


This just don't make sense and I hope when we find it it's something we can laugh about.


More information about the freebsd-questions mailing list