portmaster problems upgrading to php 5.3.4

Kelly Martin kellymartin at gmail.com
Tue Dec 28 22:24:03 UTC 2010

Hi there, I'm having problems upgrading my php installation using the
ports tree. I use the latest version of portmaster on FreeBSD
8.1-release inside a jail, with all patches. I'm trying to upgrade
from php 5.3.3_2 to the new php 5.3.4 to fix a security vulnerability.

Here is the problem. When upgrading my PHP, some of the dependencies
fail because they are "already installed". If I manually remove those
port-installed packages it continues to build past this point but then
the script breaks again with a later dependency. So the error below is
just one example of several I've encountered during the attempted
upgrade of a port. In the past this was never an issue because
portmaster is smart and would recursively install/reinstall all
required packages for me automatically. Something has changed now
because this functionality is no longer working for me.

I issue the command:
dev:/#portmaster -t -d php5

[...large amount of compilation data for php and various supporting
packages removed...]

===>  Installing for libltdl-2.2.10
===>   Generating temporary packing list
===>  Checking if devel/libltdl already installed
===>   libltdl-2.2.10 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of devel/libltdl
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/devel/libltdl.

===>>> Installation of libltdl-2.2.10 (devel/libltdl) failed
===>>> Aborting update

===>>> Update for devel/libltdl failed
===>>> Aborting update

===>>> Update for php5-mcrypt-5.3.3_2 failed
===>>> Aborting update


At this point I am half-way upgraded only. Here is what "pkg_version
-v" shows now for php:

dev:/#pkg_version -v
php5-5.3.4                          =   up-to-date with port
php5-ctype-5.3.4                    =   up-to-date with port
php5-curl-5.3.4                     =   up-to-date with port
php5-dom-5.3.4                      =   up-to-date with port
php5-extensions-1.4                 =   up-to-date with port
php5-filter-5.3.4                   =   up-to-date with port
php5-hash-5.3.4                     =   up-to-date with port
php5-iconv-5.3.4                    =   up-to-date with port
php5-json-5.3.4                     =   up-to-date with port
php5-mcrypt-5.3.3_2                 <   needs updating (port has 5.3.4)
php5-mysql-5.3.3_2                  <   needs updating (port has 5.3.4)
php5-openssl-5.3.3_2                <   needs updating (port has 5.3.4)
php5-pdo-5.3.3_2                    <   needs updating (port has 5.3.4)
php5-pdo_sqlite-5.3.3_2             <   needs updating (port has 5.3.4)
php5-posix-5.3.3_2                  <   needs updating (port has 5.3.4)
php5-session-5.3.3_2                <   needs updating (port has 5.3.4)
php5-simplexml-5.3.3_2              <   needs updating (port has 5.3.4)
php5-sqlite-5.3.3_2                 <   needs updating (port has 5.3.4)
php5-tokenizer-5.3.3_2              <   needs updating (port has 5.3.4)
php5-xml-5.3.3_2                    <   needs updating (port has 5.3.4)
php5-xmlreader-5.3.3_2              <   needs updating (port has 5.3.4)
php5-xmlwriter-5.3.3_2              <   needs updating (port has 5.3.4)
php5-zlib-5.3.3_2                   <   needs updating (port has 5.3.4)

Fortunately the security vulnerability appears to be gone now, at least:

dev:/#portaudit -Fa
auditfile.tbz                                 100% of   64 kB   64 kBps
New database installed.
0 problem(s) in your installed packages found.

So I'm probably fine but I'd like to get everything upgraded to the
same version one day soon.


More information about the freebsd-questions mailing list