ImageMagick, Djvu, and Perl-threaded - marked as IGNORE when updating

Robert Huff roberthuff at
Sun Dec 26 13:05:18 UTC 2010

Da Rock writes:
>  I'm running another set of updates, and I can't for the life of me get 
>  rid of this erroneous behaviour.
>  I run portupgrade and it tells me it can't update ImageMagick because 
>  the Djvu option requires threads, and needs perl, therefore perl needs 
>  to be threaded. So it comes up with an IGNORE which is nuts because I 
>  run threaded perl.
>  #pkg_version -v | grep perl
>  mod_perl2-2.0.4_2,3                 =   up-to-date with port
>  perl-threaded-5.10.1_3              =   up-to-date with port
>  Something I'm missing here? A fix would be nice, I should be used to it 
>  though- ImageMagick _always_ has issues for me. I just thought it'd be 
>  nice to get it updated for once- it looked so close :)

	I'm getting something similar, have been for a couple of weeks:

** Port marked as IGNORE: graphics/ImageMagick:
	OpenEXR requires threads. . Perl is non-threaded. Reinstall Perl with threads or undefine WITH_IMAGEMAGICK_PERL
** Listing the failed packages (-:ignored / *:skipped / !:failed)
	- graphics/ImageMagick (marked as IGNORE)

	(Follow-ups redirected to ports@, or I tried to.)

				Robert Huff

More information about the freebsd-questions mailing list