avahi-app port build fails on one system, not other

Steven Friedrich FreeBSD at insightbb.com
Sat Dec 18 22:18:04 UTC 2010

On Friday 17 December 2010 6:44:01 pm Marco Beishuizen wrote:
> On Fri, 17 Dec 2010, Steven Friedrich wrote:
> > I even tried portupgrade -fR avahi-app.
> > 
> > Here's the last of the log:
> > 
> > ...
> > /libexec/ld-elf.so.1: Shared object "libicui18n.so.38" not found,
> > required by "libavahi-glib.so.1"
> > ...
> I'm having this too. I think this happens because the portupgrade of
> devel/icu installs a new version of libicui18n (libicui18n.so.46) and
> deletes the old one (so.38). Lots of ports still need the old version like
> libavahi-app.
> I'll try to make a symlink so.38 to so.46 and see what happens.
> Regards,
> Marco

I tried portupgrade -fR avahi-app and several others ports.

Eventuall, out of frustration I pkg_deinstall -f avahi-app\* and then 
portupgrade -n avahi-app was successful.

I don't know why, but it worked.

System Name:         laptop2.StevenFriedrich.org
Hardware:            2.80GHz Intel Pentium 4 (HTT) with 2 GB memory
OS version:          FreeBSD 8.1-RELEASE-p2 i386 (5.1 MB kernel)
Window Manager(s):   kde4-4.5.4 
X Window System:     xorg-7.5    X.Org X Server 1.7.5

FreeBSD Audio Driver (newpcm: 32bit 2009061500/i386)
Installed devices:
pcm0: <Intel ICH6 (82801FB)> (play/rec) default

More information about the freebsd-questions mailing list