Terrible Clock Skew

Modulok modulok at gmail.com
Thu Dec 9 05:45:39 UTC 2010

On 12/8/10, Dave Cundiff <syshackmin at gmail.com> wrote:
> Hi everyone,
> I posted this to the forum as well but figured I'd try here since the
> same people might not subscribe to both.
> I've been experiencing some terrible clock skew and just can't figure
> it out. By terrible I mean I'm losing 30 minutes a day. The loss only
> occurs when I bring the system under heavy load. The load is multiple
> Rsync backups to a ZFS pool(with gzip compression) backed by a 16 disk
> Raid50. I'm using a hardware Raid controller for battery backed write
> caching.
> Mobo: Supermicro X8DTL
> CPU: Dual Intel 5620 quad cores
> Raid: Areca 1620
> I have ntp enabled but the skew happens to fast and it stops trying.
> I've tried a bunch of stuff from the various lists. I tried all my
> clock sources. TSC(-100) HPET(900) ACPI-fast(1000) i8254(0). I tried
> changing the kern.hz flag lower. I also tried disabling the enhanced
> speed step feature of this chip as per the FAQ on the site. Nothing
> works.
> Currently I'm defaults except the following settings.
> EIST Disabled in BIOS
> kern.hz="100"
> kern.timecounter.hardware=i8254
> Is there anything else I could do to debug this? I can't really blame
> the hardware because I have these same boards/chips running in Linux
> with no clock issues.

In the man page for ntpd, you might look into "The huff-n'-puff
Filter". Not saying it will help, but it seems like you've tried
everything else.


More information about the freebsd-questions mailing list