/etc/rc.d/netif & em interfaces

Brian McCann bjmccann at gmail.com
Wed Dec 1 16:15:29 UTC 2010

On Wed, Dec 1, 2010 at 10:51 AM, Brian McCann <bjmccann at gmail.com> wrote:

> This isn't a Dell PoweEdge, but at least this is two platforms it's
> happening on now.  Strangely, my VMWare virtual machines that use the
> em driver do not have this problem.
> TSO is disabled.
> I just tried adding "up" to the $ifconfig_emX lines in rc.conf, and it
> didn't help.
> What I discovered (and I'm still playing with a bit), is that it has
> to do with checksum offloading.  If you run "ifconfig emX -rxcsum",
> the interface comes back to life.  I just added "-rxcsum" to the
> $ifconfig_emX lines in rc.conf, and I can run "/etc/rc.d/netif
> restart" now, and the NIC continues to work fine.
> I tried emailing the folks @ Intel that are mentioned in the man page
> for the em driver, but the mail bounced...
> --Brian
> --

Brian (and everyone else reading the thread),

I just found this...the patch was submitted some time ago, but somehow
didn't make it into 8.1.
http://www.freebsd.org/cgi/query-pr.cgi?pr=141843 .  I'm trying it
now.  I'll keep you posted.


Brian McCann

"I don't have to take this abuse from you -- I've got hundreds of
people waiting to abuse me."
                -- Bill Murray, "Ghostbusters"

More information about the freebsd-questions mailing list