/etc/rc.d/netif & em interfaces

Brian McCann bjmccann at gmail.com
Wed Dec 1 15:51:41 UTC 2010

On Wed, Dec 1, 2010 at 9:29 AM, Brian A. Seklecki (CFI NOC)
<seklecki at noc.cfi.pgh.pa.us> wrote:
>> To make this problem even stranger, I can make a connection from the
>> server to a workstation without issue.  It appears to only be incoming
>  We've seen something very similar to this; we assumed it was
>  EEPROM corruption.
>  Is this a Dell PowerEdge by chance?
>  Do you have TSO enabled? (-tso or tso flag in $ifconfig_emX)
>  Does appending "up" to the end of if $ifconfig_emX solve the problem?
> ~BAS

This isn't a Dell PoweEdge, but at least this is two platforms it's
happening on now.  Strangely, my VMWare virtual machines that use the
em driver do not have this problem.

TSO is disabled.

I just tried adding "up" to the $ifconfig_emX lines in rc.conf, and it
didn't help.

What I discovered (and I'm still playing with a bit), is that it has
to do with checksum offloading.  If you run "ifconfig emX -rxcsum",
the interface comes back to life.  I just added "-rxcsum" to the
$ifconfig_emX lines in rc.conf, and I can run "/etc/rc.d/netif
restart" now, and the NIC continues to work fine.

I tried emailing the folks @ Intel that are mentioned in the man page
for the em driver, but the mail bounced...


Brian McCann

"I don't have to take this abuse from you -- I've got hundreds of
people waiting to abuse me."
                -- Bill Murray, "Ghostbusters"

More information about the freebsd-questions mailing list