IPv6 rtadv on FreeBSD 8.1?

Carl Johnson carlj at peak.org
Mon Aug 2 04:32:04 UTC 2010

Carl Johnson <carlj at peak.org> writes:

> I have running versions of 7.3 and 8.0, so I tried experimenting with
> 8.1 in VirtualBox, but I ran into a couple of problems.  I have an 8.0
> system that is running a IPv6 tunnel to sixxs.net, and it is running
> rtadvd to act as the gatway for my network.  On the 8.1 system I
> enabled IPv6 in rc.conf, but it is not picking up the advertised
> address.  I can add it manually, and have put it in rc.local for now,
> but it seems it should work automatically as my others do.  I noticed
> that the ifconfig output shows a new line that is not in 8.0:
>         nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
> Is there something that has changed in 8.1 that I have to enable, or
> is there a problem with 8.1?  IPv6 is working to the extent that it
> did assign a link-local address, and I can use that address as long as
> I specify the interface.  My configuration is the same, and I didn't
> have to enable anything on the others to get the global address
> assigned automatically.

This is a followup to note that it does work when I run it on native
hardware instead of under VirtualBox.  My version of VirtualBox is an
old one (2.1.4) running under Linux, so maybe it has some bugs. I had
installed FreeBSD under VirtualBox, but installed to a primary
partition specifically so that I could later boot directly into it.
The odd thing is that I have a similar FreeBSD 7.3 installation which
does work properly under VirtualBox.

Now if I could just figure out why gnus doesn't work right under emacs
I could finish migrating from Linux to FreeBSD.
Carl Johnson		carlj at peak.org

More information about the freebsd-questions mailing list