Problem installing FreeBSD 7.1 RELEASE.

Rom Albuquerque a_romolo at
Thu Sep 10 23:21:42 UTC 2009

Hi. I'm having trouble installing 7.1 release. 

The details of my system : 

Motherboard : EliteGroup (A740GM-M)
RAM :         3G DDR2 800Mhz
CPU :         AMD Athlon 64 x2 Dual Core processor
Disk :        WD 500GB SATA 
DVD :         Samsung DVD/Writer "Super Write Master"
Primary OS :  Windows XP sp3

I'll list the problems and the attempts I've tried to get around them. 

Problem #1

The CD/DVD drive can not be mounted by sysinstall. 

I have a SAMSUNG DVD writer drive attached to my ATAPI IDE interface. 
I have a WD 500GB SATA Drive attached to my SATA interface. 

The system boots off the CD, runs sysintall. 

I'm able to allocate storage for the FREEBSD partition and then create the 
individual slices for the default file systems. (/, swap, /var, /tmp, /usr)

When choosing the instalation media as CD/DVD, an error message saying that the 
CD/DVD drive was not found pops up. 

I've tried every option on the boot program, they all fail to load the CD/DVD drive
and can't proceed with the instalation. 

I've tried changing the DVD drive to a nother CD/RW drive attached to the same ATAPI
controller, the problem persist as before, no change. 

This leads me to my next attempt to install the system from a disk PARTITION. 

Problem #2

Unable to mount the disk partiton at the time of install.

Ok, I've created a new extended partition with Partition Magic to hold the contents
of the install CD. 

This new partition sits third on the list as follows : 

 a) NTFS partition with my XP installation
 b) FreeBSD partiton where the system will be installed.
 c) The new FAT partiton where the contents of the FREEBSD cd is copied into the 
    directory named E:\FREEBSD.

I've copied the entire CD to this new partition. 

Back to sysinstall, when choosing the new instalation media "Install from DOS partition"

I get an error message saying "Unable to mount /dev/ad8s3 to /dist", and the problem
of not finding the DOS partition where the contents of the FREEBSD cd were copied to
continues, keeping me from progressing with the install. 

The next attempt was trying to install from a filesystem. 

When selecting this option, a dialog "from sysinstall" pops up asking to list the 
complete path name of where the FREEBSD files were copied to this disk partition. 

I enter /dev/ad8s3:/FREEBSD and an error message saying that "it can not find the 
disk partition" comes up keeping me from progressing with the install. 

I've looked at the FreeBSD handbook online, but could not find further details about 
installing the system from a disk partition.

Any pointers as to what proper measures to take to try to get past this problem. ? 

Can someone suggest some other way to get the system installed. ? 

Oh, I've also tried PC-BSD, but that stops right away with an error message of 
"Error loading image" since it can not find the CD/DVD drive again. 

I'll appreciated if you can provide further details of how to proceed, point me to the
direction where I can get more details. 

Your response is greatly appreciated. 


a_romolo at

Windows Live: Keep your friends up to date with what you do online.

More information about the freebsd-questions mailing list