error while printing from Java to CUPS

Matthias Apitz guru at
Tue Oct 13 10:56:12 UTC 2009


Some Java applications, like openproj for example, are unable to print
to the CUPS printing system; this seems to be a know problem in Java and
if you do a search in Don Google you will information and workarounds,
like this, for example:

Diagram printing is not working on Linux OS

The problem is related with the Linux cups package update.
This problem is Sun Java bug and description of this problem is
published in the Java Bug Database: To solve
diagram printing problem we would suggest to use 1.6.0_10 JVM or later,
because this issue is solved in these java versions.
If you can not use the 1.6.0_10 JVM or later, other possible solution
would be the following:
1.Open the file /etc/cups/printers.conf
2.Before each line with the text </Printer>, add the following line:
Options orientation-requested 3

The referenced
explain all the details of the bug...


I've tried to insert the proposed change in
/usr/local/etc/cups/printers.conf but it does not help. This is with
cups-base-1.3.9_3 in a 8-CURRENT. As well it says that there is a fix in
Java in 1.6.0_10 or later... I have dk- and it seems no to
be fixed :-(

Any ideas?


Matthias Apitz
t +49-89-61308 351 - f +49-89-61308 399 - m +49-170-4527211
e <guru at> - w
Vote NO to EU The Lisbon Treaty:

More information about the freebsd-questions mailing list