Upgrade to 7.2 broke network connections

fbsd-ml at gehlbach.com fbsd-ml at gehlbach.com
Fri Oct 9 02:57:25 UTC 2009

Today I updated a server from 6.4 to 7.2.  I cvsup'ed, built world, built
kernel, installed kernel, installed world, mergemastered, and rebooted. 
And sat there, while ntpdate timed out trying to connect to four different
servers, while interface status messages slowly scrolled:
tx0: device timeout 2 packets
tx0: seems we can continue normally
rl0: watchdog timeout

When it finally timed out, and I logged in, I found that I could ping, I could ping (tx0 interface), I could ping the rl0
wan interface, I could not ping the gateway or anything outside of the

Looking at dmesg later, I found the same timeout messages repeated again
and again, and I found further error messages:
tx0: reinitialization
tx0: ERROR! Can't stop TxDMA
tx0: ERROR! Unknown PHY selected

and repeated periodically:
tx0: reinitialization
tx0: ERROR! Unknown PHY selected

I built and installed the generic kernel, and tried again.  Same deal.  I
disabled ipfilter and ntp in rc.conf, removed the configuration lines for
all but one interface, and rebooted.  Same deal, just shorter boot time
without having to wait for ntpdate (grin)

I thought, ok.....really old NICs.  There were some warnings about
deprecated features in bootup.  I took out both NICs and put in an Intel
Pro 10/100/1000 -- obviously supported.  Same deal.

I previously attempted to update this server several months ago, going
from 6.something to 7.1, and had this same problem.  After several
frustrating days, I restored from backup and updated to latest 6.x, which
worked fine.

So I assume that I have something configured wrong.  If there were
hardware compatibility issues this big, this version would never have gone
to stable, and people would be screaming about it all over the mailing
lists.  So my question is.....what should be my next troubleshooting step?

Thanks for your time,
Renee Gehlbach

More information about the freebsd-questions mailing list