ZFSROOT / Custom Kernels [or upgrades]

Philip M. Gollucci pgollucci at p6m7g8.com
Mon Nov 30 07:17:58 UTC 2009

Hi All,

I followed this wiki link to setup our server [sigyn.apache.org]
(Dell r710 with 4 disks mfid[0123] as raidz2)

Rebooted all was well.

2) off on another 'build' box [loki.apache.org], I had compiled
release/8.0.0 userland+kernel [with LOADER_ZFS_SUPPORT=yes].
Whats the ETA for MFC from trunk->stable/8 for

** FWIW, loki is working nicely on 8.0-RELEASE geom+zfs.

3) I nfs mounted /usr/src, and /usr/obj on sigyn from loki.
$ cd /usr/src
$ sudo make installkernel KERNCONF=SIGYN

It fails to mount from zfs:zroot upon reboot. Via great hoops and magic
I got back into the fixit on remote console. I didn't see a loader.old
or a zfsboot. So I repeated the steps in wiki to install zfsboot.
Rebooted, same diff.

Jumped backed to fixit and reverted the kernel to a stock GENERIC that
worked the 1st time.  Same error again.
cd /boot
$ mv kernel kernel.cust
$ mv kernel.old kernel

So assuming you are lucky enough to get a zfsroot system.  Is there an
actual upgrade path ? Am I missing something stupid ?

Any help greatly appreciated.

I have a few days to play with this machine before we forgoe zfsroot and
drop back to geom gmirror.

I'm at a datacenter for $work on Monday/Tuesday so I'll be spare over

1024D/DB9B8C1C B90B FBC3 A3A1 C71A 8E70  3F8C 75B8 8FFB DB9B 8C1C
Philip M. Gollucci (pgollucci at p6m7g8.com) c: 703.336.9354
VP Apache Infrastructure; Member, Apache Software Foundation
Committer,                        FreeBSD Foundation
Sr. System Admin,                 Ridecharge Inc.
Consultant,                       P6M7G8 Inc.

Work like you don't need the money,
love like you'll never get hurt,
and dance like nobody's watching.

More information about the freebsd-questions mailing list