Mail not working [SOLVED]

Matthew Seaman m.seaman at
Sat Nov 28 21:20:18 UTC 2009

Dimitri Yioulos wrote:

> I can't believe it.  After all this time hacking away, I solved my issue rather easily.
>  I made sure sendmail was turned off, then deinstalled/reinstalled postfix-current from
> ports.  I had to tweak some directives in mailer.conf and based on a couple of
> posts I googled.  I made sure sendmail wouldn't start, then started postfix with
> "/etc/rc.d/sendmail onestart" (Q: why is postfix invoked by starting sendmail?).  Was
> able to send mail locally and externally through MTA.

It isn't usually.  I guess it only works because mailer.conf says the real sendmail
binary is the one installed by postfix.

The usual arrangement is to turn off sendmail and enable postfix from /etc/rc.conf
by the following:



Then you should be able to start postfix by:

   # /usr/local/etc/rc.d/postfix start

although you'll have to make sure the instance you started as a pseudo-sendmail is
killed first.



Dr Matthew J Seaman MA, D.Phil.                   7 Priory Courtyard
                                                  Flat 3
PGP:     Ramsgate
                                                  Kent, CT11 9PW

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 259 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-questions mailing list