Mail not working [SOLVED]

Dimitri Yioulos dyioulos at
Sat Nov 28 21:06:27 UTC 2009

On Sat, 28 Nov 2009 12:56:57 -0500, Dimitri Yioulos wrote
> Greetz to all.
> I've never been able to get a mail server working on my FreeBSD installation.  
> While I recently upgraded to 8.0-RELEASE, it hasn't worked since my initisl 
> 7.0-RELEASE installation.  This is not a major server, so I haven't fussed 
> with it up to now.  But, I would like to finally fix it.
> I've tried various combinations of postfix and sendmail, but all have failed.  
> It doesn't matter to me whether I run postfix or sendmail, though I have far more
> experience with sendmail.  I believe that both postfix and sendmail are currently
> installed, with postfix being the mail server.  I want to forward mail to my sendmail
> MTA for distribution, which I'm doing successfully with many other *nix boxes.
> Here's what I currently see in /var/log/messages whenever I try to send a 
> message from the FBSD box:
> Nov 28 04:15:30 marshfield kernel: pid 11721 (mailwrapper), uid 0: exited on 
> signal 11
> (core dumped)
> and in /var/log/maillog:
> Nov 26 21:35:29 marshfield postfix/master[946]: daemon started -- version 2.7-
> 20091008, configuration /usr/local/etc/postfix
> Here's at least a snippet from
> mydomain =
> readme_directory = no
> myorigin = $mydomain
> mydestination = $mydomain
> #relayhost = [mail1.$mydomain]
> relayhost =
> data_directory = /var/db/postfix
> transport_maps = /usr/local/etc/postfix/transportsmtpd_recipient_restrictions 
> = permit_my networks
> and mailer.conf:
> sendmail        /usr/sbin/sendmail
> send-mail       /usr/sbin/sendmail
> mailq   /var/spool/mqueue
> newaliases      /usr/bin/newaliases
> I've googled, etc., but haven't come up with a solution.  Your help would be greatly
> appreciated.
> Thanks.

I can't believe it.  After all this time hacking away, I solved my issue rather easily.
 I made sure sendmail was turned off, then deinstalled/reinstalled postfix-current from
ports.  I had to tweak some directives in mailer.conf and based on a couple of
posts I googled.  I made sure sendmail wouldn't start, then started postfix with
"/etc/rc.d/sendmail onestart" (Q: why is postfix invoked by starting sendmail?).  Was
able to send mail locally and externally through MTA.

Sorry for the noise.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the freebsd-questions mailing list