Cut/Paste with USB mouse inoperative

Carmel carmel_ny at
Tue Nov 10 22:13:16 UTC 2009

On Tue, 10 Nov 2009 22:03:25 +0100
Polytropon Polytropon <freebsd at> replied:

>On Tue, 10 Nov 2009 15:33:46 -0500, Carmel <carmel_ny at>
>> I just switched from a regular mouse to a USB mouse wireless mouse.
>> The mouse works fine except that the cut/paste middle button feature
>> is inoperative. The scroll feature works correctly though. I removed
>> all references to 'mouse' in the /etc/rc.conf file and rebooted;
>> however, nothing changed.
>have you first tried the obvious workaround for nonstandard
>mice with "not three" buttons, i. e. pressing the left and
>the right button together to emulate the middle button? If
>this works, there seems to be some misconfiguration.

Negative, it does not work.

>I'm not using wheel mice (nor am I using cordless mice),
>so I cant help much. I'm using the middle mouse button
>for cut / paste (click), and for the vertical scroll
>functionality (press + move).
>> I then tried to change mouse port from the default:
>> moused_port="/dev/psm0" to moused_port="/dev/usm0"
>> That did no help either.
>USB mice don't need to be setup via moused, as far as I
>remember. Just comment out the moused_* entries in the
>/etc/rc.conf file.
>> Is there anyway to get this to work?
>You could try to set it explicitely in /etc/X11/xorg.conf:
>Section "InputDevice"
>        Identifier      "Mouse0"
>        Driver          "mouse"
>        Option          "Device"                "/dev/sysmouse"
>        Option          "Protocol"              "Auto"
>        Option          "ZAxisMapping"          "4 5"
>        Option          "Emulate3Buttons"
>        Option          "EmulateWheel"
>        Option          "EmulateWheelButton"    "2"
>The buttons are 1 and 3 for left and right, 2 should be
>the middle one, 4 and 5 are up / down of the wheel. You
>can always use the xev program to check what actually
>happens when you use the different mouse buttons.

'X' has nothing to do with it. It fails to work both in and out of 'X'.
With the old mouse it worked fine.

>If you're relying on HAL and DBUS, well, ... :-) I think
>there must be some kind of workaround to make things work
>again with HAL that worked before with X, such as special
>settings for mice.

Way more trouble than it is worth. I might just go back to the old
mouse. Strangely enough, the new mouse works perfectly under Windows so
I know it is not broken.

carmel_ny at


Will Rogers never met you.

More information about the freebsd-questions mailing list