run_interrupt_driven_hooks: still waiting... for xpt_config

Chris Whitehouse cwhiteh at
Sat May 16 23:00:18 UTC 2009

Hi all

I'm trying to install on a new motherboard ASUS M3N78-EM. While booting 
from CD I'm getting

run_interrupts_driven_hooks: still waiting after 60 seconds for xpt_config

This is repeated a few times then installation stops and the machine 
stops responding.

I've tried various versions, including 6.4R, 7.0R 7.2R and
8.0-CURRENT-200905-i386-disc1.iso. I've also tried SATA mode and AHCI 
mode for the SATA controller.

I get a panic from the 8-CURRENT snapshot. The others might be panicking 
but I guess their standard kernel doesn't have debug stuff

There is a reference to something being patched here

but I can't see a patch or what has been patched.

Thing is if this board is not going to work I need tell the shop I am 
going to send it back in 2
days by their terms and conditions. So my question right now is - is 
this something that (developer willing) could be
fixed? If yes I will take a chance that a developer would be willing and
keep the board. I would rather keep the board if possible.

Backtrace from 8-CURRENT (typed by hand).

panic: run_interrupt_driven_hooks: waited too long
KDB: enter: panic
[thread pid 0 tid 100000 ]
stopped at   kdb_enter+0x3a: movl   $0,kdb_why
db> bt
Tracing pid 0 tid 100000 td 0xc0d88fd0
kdb_enter(c0c3d8cf,c0c3d8cf,c0c3feac,c1820d08,0,...) at kdb_enter+0x3a
panic(c0c3feac,0,c0c3fe43,70,ea60,...) at panic+0x136
at run_interrupt_driven_config_hooks+0x1c7
mi_startup() at mi_startup+0x96
begin()at begin+0x2c

I can build a debug kernel on 7.2R or any recommended version onto a 
spare hard disk and use it to boot this machine to get debugging info.

Much thanks


More information about the freebsd-questions mailing list