Keyboard not working in gnome?

Christopher Arnold chris at
Fri May 15 16:56:54 UTC 2009

Problem solved, see below..

On Fri, 15 May 2009, Christopher Arnold wrote:

> On Fri, 15 May 2009, Robert Noland wrote:
>> On Fri, 2009-05-15 at 13:05 +0200, Christopher Arnold wrote:
>>> In Xorg.0.log i see:
>>> (II) config/hal: Adding input device USB Receiver
>>> (EE) config/hal: NewInputDeviceRequest failed (8)
>>> (II) config/hal: Adding input device AT Keyboard
>>> (EE) config/hal: NewInputDeviceRequest failed (8)
>>> (The at part makes sense, i only have USB on this machine)
>>> So i guess this is the problem and that a rebuild of gnome/X11 did not
>>> help. It seems fairly close to the issues with hald/xorg.conf that we saw
>>> the last time upgrading gnome.
>>> What is actually the right config nowdays?
>>> I have the following in xorg.conf:
>>> Section "ServerLayout"
>>>      Identifier     "Simple Layout"
>>>      Screen         "Screen 1" 0 0
>>>      InputDevice    "Mouse1" "CorePointer"
>>>      InputDevice    "Keyboard1" "CoreKeyboard"
>>>      Option         "AllowEmptyInput" "off"
>>>      Option         "AutoAddDevices" "off"
>>> EndSection
>> Using the above, you shouldn't need the lines below.  Your devices need
>> to be statically configured in xorg.conf.  If you are using hald, then
>> remove both the AllowEmptyInput and AutoAddDevices lines above.  I
> When i commment theese out i get neither keyboard or mouse.
> Also i notice in the xorg logfile that my "Keyboard1" gets ignored 
> alltogether. That is if i would have got the keyboard to work i would have a 
> us one instead of my swedish.
>>> And in /etc/rc.conf:
>>> bus_enable="YES"
>>> hald_enable="YES"
> If i comment these out then gdm dosn't even start since gdm requiers them i 
> guess.
With AllowEmptyInput and AutoAddDevices set to "off" and both dbus and 
hald enabled it now works... Why?

Well i tried and xterm as usual and it didn't work. Decided to check if 
another program accepted input to rule out an error in xterm. So i used 
preferences/keyboard instead. I didn't expect it to work so i just pressed 
a key and kept it down. Klick and then characters!

So in the end i managed to find out that slow keys somehow had become 
enabled in universal access preferences....


But it is a bit strange that your suggestions did not work.
How come some people need the AllowEmptyInput and AutoAddDevices lines but 
not others?


More information about the freebsd-questions mailing list