issues in XFCE 4.6

Fbsd1 fbsd1 at
Sat Mar 14 00:08:35 PDT 2009

Keith Seyffarth wrote:
>> Your problem is not xfce but xorg. It went through massive changes in 
>> 7.1 and it's now mandatory to have a /etc/X11/xorg.conf. You have to add
>> Option "AllowEmptyInput" "Off" statement as last line in "ServerLayout" 
>> section. Doing console command Xorg -config /etc/X11/xorg.conf will 
>> build you one.  By the way i used the package version of xfce4 on 7.1 
>> and it's working just fine after i added the above xorg fixes.
> That line was already in xorg.conf (it was necessary to get a mouse to
> work after the last xorg update in January). However, I did not have
> it as the last line in the ServerLayout section. I moved it to the
> last line, but that didn't make a difference.
> There's still no XFCE menu, and without the ability to update the
> settings in XFCE, it's pretty much unusable...
> Keith
As i said the packages worked for me. Blow away the xfce and xorg ports 
and do the xorg mega package and the xfce mega package. if that fails 
then bkup your user data and install a clean virgin version of 7.1 and 
the xorg and xfce packages.

More information about the freebsd-questions mailing list