Problem building ports : 1) abiword; 2) xine

bf bf2006a at
Fri Mar 13 15:54:15 PDT 2009

--- On Fri, 3/13/09, Manish Jain <invalid.pointer at> wrote:

> From: Manish Jain <invalid.pointer at>
> Subject: Re: Problem building ports : 1) abiword; 2) xine
> To: bf2006a at
> Cc: freebsd-questions at
> Date: Friday, March 13, 2009, 8:14 AM
> Hello BF/Everyone,
> Thanks for your advice. But the problems just don't
> seem to go away. I ran 'make config'
> inside /usr/ports/ftp/curl and was able to rectify the
> problem. I was installing curl
> as part of the xine build process. Once curl got built,
> xine got built too. The install
> went smoothly enough. But when I ran xine& from a
> gnome-terminal, the ui loaded,
> got stuck for hours and simply would not respond to any
> mouse clicks. I finally had
> to do a kill -9. (Which is why I dropped curl from the
> subject of this message and
> replaced it with xine).
> As for abiword, I downloaded the latest ports tarball a few
> minutes back. Building
> abiword stops with pretty much the same error :
> In file included from
> /usr/local/include/gtk-2.0/gtk/gtkactiongroup.h:34,
>                  from
> /usr/local/include/gtk-2.0/gtk/gtk.h:38,
>                  from goffice-gtk.c:27:
> /usr/local/include/gtk-2.0/gtk/gtkitemfactory.h:50:
> warning: function declaration isn't a prototype
> goffice-gtk.c:1041: error: static declaration of
> 'gdk_cairo_set_source_pixbuf' follows non-static
> declaration
> /usr/local/include/gtk-2.0/gdk/gdkcairo.h:36: error:
> previous declaration of
> 'gdk_cairo_set_source_pixbuf' was here
> goffice-gtk.c:1152: error: static declaration of
> 'gtk_dialog_get_response_for_widget' follows
> non-static declaration
> /usr/local/include/gtk-2.0/gtk/gtkdialog.h:149: error:
> previous declaration of
> 'gtk_dialog_get_response_for_widget' was here
> gmake[3]: *** [goffice-gtk.lo] Error 1
> gmake[3]: Leaving directory
> `/usr/ports/devel/goffice04/work/goffice-0.4.3/goffice/gtk'
> gmake[2]: *** [all-recursive] Error 1
> gmake[2]: Leaving directory
> `/usr/ports/devel/goffice04/work/goffice-0.4.3/goffice'
> gmake[1]: *** [all] Error 2
> gmake[1]: Leaving directory
> `/usr/ports/devel/goffice04/work/goffice-0.4.3/goffice'
> gmake: *** [all-recursive] Error 1
> *** Error code 2
> Stop in /usr/ports/devel/goffice04.
> *** Error code 1
> Stop in /usr/ports/editors/abiword.
> Any help with xine and/or abiword would be greatly
> appreciated.
> Thank you and Regards
> Manish Jain
> invalid.pointer at

I haven't (re-)built goffice for a few days, but I didn't have
any problems.  Furthermore, I haven't seen any other reports of
problems.  It is likely then that the problem is peculiar to
your own system.  So eliminate any potential problems

First, make sure that your ports tree is intact, up-to-date, and
in the right place -- portsnap or csup would probably be best
for this. 

Also make sure that any environment variables or settings
that you have changed in /etc/make.conf won't interfere with your

Then make sure your ports index is up-to-date, by running
"make fetchindex" in the /usr/ports directory, or by rebuilding
it via "make index" if you must (this second option is more
time-consuming, and not needed unless you absolutely must have
the latest index after a recent ports tree update, or have made
some local changes to your ports tree.)  If you have 
ports-mgmt/portupgrade or ports-mgmt/portupgrade-devel installed,
you can run "portsdb -Fu" instead of the above.

Now check to make sure that all of the ports that you
have installed are up-to-date, especially the ones that are
listed as prerequisites for the port you are trying to build.
You can do this by running "pkg_version -vI -l '<'". Update
any ports that are out of date, _in dependency order_. (This 
is obviously a pain to do by hand, so I recommend that you
use ports-mgmt/portupgrade, ports-mgmt/portupgrade-devel, or
ports-mgmt/portmaster to do this for you.  Read the manpages
for these ports for instructions on how to use them.  Or you
could just remove everything via "pkg_delete '*'", clean out
/usr/local, and then start over.  This is the safest, but it
can be time-consuming if you have lots of software installed.)

Now build and install the ports you want by running "make clean
install" in each of the port directories.  Don't forget the
"clean", as you don't want to build old or corrupted versions
of the ports. Again, if you have some version of portupgrade or
portmaster installed, you could use those instead.

If the build still fails, and your installed software seems to
be otherwise intact -- there has been no filesystem corruption,
etc. -- send the build transcript by email to the port
maintainer or file a PR ("Problem Report").



More information about the freebsd-questions mailing list