The Gimp

Rob Hurle rob1940 at
Tue Jun 23 12:44:48 UTC 2009

  Due to some meteorological disasters I've had to replace my 6.1
FreeBSD system and I've installed 7.2 on the refurbished i386

freebsd [22:03] ~>uname -a
Fri May  1 08:49:13 UTC 2009

My desktop is KDE Version 4.2.2 (not yet sure that this is an
improvement over the previous version).  I'm starting to re-install
software using portupgrade (portinstall).  I've a few problems with
that, but I'll leave that to another post.  The immediate problem is
that I've used portinstall to install gimp (picture processing
software) which I was happily using on the previous version.  It
installs OK (after a fearful amount of time) but when I start it, I
get a segmentation fault:

freebsd [22:07] ~>gimp &
[1] 3696
freebsd [22:09] ~>
[1]    Segmentation fault            gimp
freebsd [22:09] ~>

If I run as root, there is no problem:

freebsd [22:09] ~>sudo gimp &
[1] 3700
freebsd [22:10] ~>
[1]  + Suspended (tty output)        sudo gimp
freebsd [22:10] ~>fg
sudo gimp

freebsd [22:11] ~>

It starts OK and I can use it fine.  The config file ".gimp-2.6" is
saved in root's home directory.  I've tried RTFM, but there is no
information on this problem.  Maybe it's due to some library having
the wrong permissions and I should search the system for files with
544 permissions or something.  Does anyone have a clue as to what's
going on, or should I report a bug?  Thanks heaps.

Rob Hurle
Rob Hurle
Research School of Pacific and Asian Studies, ANU
e-mail:              rob1940 at
Telephone (ANU): +61 2 6125 3169
Mobile (in VN):  +84 948 243 538 (Currently in Australia)
Mobile (in OZ):  +61 417 293 603 (Currently in Australia)

More information about the freebsd-questions mailing list