badly munged system

Eitan Adler eitanadlerlist at
Fri Jul 17 21:28:06 UTC 2009

I tried to do a make buildworld, make buildkernel, make installkernel,
reboot, make installworld from an old version of 7.2-STABLE to revision
195666. I was in single user mode the entire time.
The first three steps worked perfectly. The final step resulted in an
error which I forgot to log. I then proceeded to do a make clean and try
to rebuild the world.
This results in the following error:
cc -O2 -fno-strict-aliasing -pipe

clude -c /home/src/stable7/usr.bin/makewhatis/makewhatis.c
/home/src/stable7/usr.bin/makewhatis/makewhatis.c:146: warning: 'struct

declared inside parameter list
/home/src/stable7/usr.bin/makewhatis/makewhatis.c:929: error:
dereferencing poin

ter to incomplete type
*** Error code 1

Stop in /home/src/stable7/usr.bin/makewhatis.
*** Error code 1

Along with this error I am now missing quite a number of system files:
among them include /usr/share/mk/
/libexec/ sort: Shared object has no run-time symbol table
and man.

How could I get out of this state without losing data?

More information about the freebsd-questions mailing list