How to test an unsupported scanner (CanoScan LiDe 90)?

Polytropon freebsd at
Sun Sep 14 17:36:46 UTC 2008


Seems that the CanoScan LiDe 90 is one of the scanners built by
Canon that are not supported well. That's a reason to avoid them. :-)
I had similar issues with a LiDE 45 (I think it was), and I did
soon replace it with a SCSI scanner that worked out of the box
without problems.

On Sun, 14 Sep 2008 11:40:54 +0200, Peter Ulrich Kruppa <ulrich at> wrote:
> Peter Ulrich Kruppa schrieb:
> > I have purchased a scanner yet unsupported by sane
> > (CanoScan LiDe 90).

Mayve the SANE team will get this scanner to work later on. But
at this point in time, the scanner will be outdated. :-)

> In the meantime I have played around a little bit:
> I put vendor and product id's into
> /usr/src/sys/dev/usb/uscanner.c and usbdevs and rebuilt
> my kernel.
> So now I get
>    # dmesg | grep uscanner
>    uscanner0: <Canon CanoScan, class 255/255, rev 2.00/3.07,
>    addr 2> on uhub1
> which changes:
>    # sane-find-scanner -q
>    found USB scanner (vendor=0x04a9, product=0x1900) at
>    /dev/uscanner0
> Also I tried an appropriate entry in
> /usr/local/etc/sane/genesys.conf	
> but the result of
>    # scanimage -L
> remains the same (not identified) and
>    # scanimage -d genesys:/dev/uscanner0 > image.pnm
>    scanimage: open of device genesys:/dev/uscanner0 failed:
>    Invalid argument

This indicates that this scanner works differently than those
usually supported by the genesys backend. I "love" Canon for
making things complicated exactly this way.

Maybe this scanner is compatible to another driver, but that's
only a guess. Maybe it's not compatible to anything that exists.

>From Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list