Pasting via ssh causes data loss

Chris eagletree at
Sun Nov 30 18:04:06 PST 2008

On Nov 30, 2008, at 2:20 PM, Eugene Pimenov wrote:

> On 30 нояб, 23:20, Ivan Voras <ivo... at> wrote:
>> I regularly do copy-pastes of textual data of that size (and  
>> larger) in
>> interactive sessions (with text editors) without problems, between
>> FreeBSD machines and from Linux to FreeBSD machines. Are you sure  
>> it's
>> not a problem with your terminal application and not on the server  
>> side?
>> (try a different terminal).
> Tried a different terminal. iTerm to be exact. The same problem, the
> same number of bytes.
I was curious about your situation and set up a couple of tests. Noting
you mentioned iTerm, I thought I might be able to recreate it on a Mac
(OS-X 10.4 with 1.4.3 (100) version Terminal, I had removed iTerm due
to unreliability sometime back).

I copied a 23094 byte program I was working on locally in MacVIM. I  
first did
a cat >testfile then pasted through an ssh connection  
over satellite (very
bad connection) into a FreeBSD 7.0 box I built in the last month. At
the far end it received 23094 bytes. sftp of the file to the remote and
diff showed no differences. I then opened an ssh session to a FreeBSD  
on my local lan and repeated with the same results. No problems.

The problem does not appear to be obvious or common so there must be  
unique about how this situation if you have reproduced it on two
different terminal programs using ssh that would work correctly to other
servers using the same shell and collection method (e.g. cat >blah).

Something missing here. Have you checked if you have
errors shown on the interface of the server? Are there losses if you  
the files from your machine to the remote (Try pushing a 1.5 MB file and
see if that shows failures). Did you install something other than the  
OpenSSH on the server? Do the text files have something other than text
in them or even control sequences for the remote? Just taking  
potshots here.

A somewhat side note here, I would personally never think to move  
files this
way since it's quite possible that content of files can disrupt the  
I tend to use sftp.

> A friend of mine tried from gentoo linux on his laptop (he'is using
> yakukake (terminal)), and reproduced the same issue, but different
> amount of bytes (3221 for the server that receives 5181 from me).
> Is there some stupid sysctl setting? or something like that? I'm so
> tired of pasting into a linux box and wget from it into a freebsd box.
>>  signature.asc
>> < 1KбПросмотретьЗагрузить
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions- 
> unsubscribe at"

More information about the freebsd-questions mailing list