SMB share not mounting at startup

Stephen Allen sdafreebsduk at
Thu May 8 13:07:42 UTC 2008

I copied /root/.nsmbrc to /etc/nsmb.conf with security at 600, and it 
doesn't work.  With security at 777 it still doesn't work.

Any more suggestions?

Many thanks,
Steve :)

Dominic Fandrey wrote:
> Stephen Allen wrote:
>> I am trying to mount an SMB share at startup.  I have configured (as 
>> root) .nsmbrc so I don't have to type a password.  When I run "mount 
>> -a", it mounts beautifully.
>> However, when restarting the server, it will not mount automatically. 
>> According to rc.conf(5), smbfs is part of 'netfs_types' so rc should 
>> wait until after the network is started before trying to mount it (so 
>> shouldn't fail).  I have an entry in /etc/fstab as follows:
>> //backup at snap-cms/unix_backups  /mnt/snapserver  smbfs  rw  0 0
>> Does anyone have any ideas?  I'm wondering if the .nsmbrc file can't 
>> be read because rc isn't running as root - and if so, where can I put 
>> .nsmbrc?
>> Many thanks,
>> Steve :)
> I don't think $HOME or $USER are already set at the time hard disks are 
> mounted. Use the global file /etc/nsmb.conf as suggested in another mail.

More information about the freebsd-questions mailing list