socket bind failure - errno 49

Balaji Kasthurirangan kasthurirangan.balaji at
Sat May 3 11:22:14 UTC 2008


I have tried searching the archives and in vain. Hence i am posting to this
group. If this not the right one, pls direct me.

I am using FreeBSD 6.1. Initially i was able to create socket, bind it and
do all sorts of things. But when i tried now, it isn't working. I am trying
after a long gap. The errno is 49 - invalid address.
I used gethostbyname and it returns whatever is there in /etc/hosts. I have
checked the /etc/resolv.conf. My config details are



/etc/hosts Balaji localhost
::1 localhost



I tried setting Balaji to, still it doesn't work. Pls help me.

Also, when my system boots, couple of eye-catchy messages

syslogd: can't bind address

sm_mta[root]:syserror : can't assign address // i hope this is wrt mail/smtp

My suspect is that, the error happens after my system was shutdown
improperly(sudden power off and my laptop battery isn't working, and
ofcourse i am freebsd on my toshiba tera laptop - P4).
I have done fdisk to ensure my disk is clean.


More information about the freebsd-questions mailing list