OpenOffice 2.3

Nikola Lečić nikola.lecic at
Thu Mar 27 11:38:22 PDT 2008

Hash: RIPEMD160

On Thu, 27 Mar 2008 18:18:57 +0000
Mike Clarke <jmc-freebsd at> wrote:
> On Thursday 27 March 2008, Nikola Lečić wrote:
> > (BTW, there are pre-built packages for all OpenOffice versions:
> >
> >  
> >
> >s/
> >
> >  -- have you considered trying them?)
> I tried this about a week ago without much success. I could get 
> to run but when I tried to open an .odt with 
> writer it hung with the following errors:
> (process:2307): GLib-GObject-CRITICAL **: gtype.c:2242:
> initialization assertion failed, use IA__g_type_init() prior to this
> function
> (process:2307): GLib-CRITICAL **: g_once_init_leave: assertion 
> `initialization_value != 0' failed
> (process:2307): GLib-GObject-CRITICAL **: g_object_new: assertion 
> `G_TYPE_IS_OBJECT (object_type)' failed
> I also tried from the same directory. 
> That "sort of" worked - I could open files but the formatting was
> wrong with lots of spaces missing. But 2.4 is still in development (I
> think) so things like that might be to be expected.

According to what can be read on the page I sent with my previous mail,
it seems to be a GTK-related issue. I confirm that all 7-stable
OpenOffice packages (including 2.3.1_1) work perfectly on my plain
7.0-RELEASE/i386 install, but with *up-to-date* ports, not with
precompiled packages shipped as a part of the release. So,

1) Update your ports, and don't forget ports/UPDATING;
2) Try OOO_FORCE_DESKTOP=gnome if you're using KDE.

- -- 
Nikola Lečić = Никола Лечић
fingerprint : FEF3 66AF C90E EDC3 D878  7CDC 956D F4AB A377 1C9B
Version: GnuPG v2.0.8 (FreeBSD)


More information about the freebsd-questions mailing list