6.3 And VIA 8237S Controller

Tim Daneliuk tundra at tundraware.com
Fri Mar 14 06:59:58 UTC 2008

Tim Daneliuk wrote:

One point of clarification I neglected to mention in the 
description below.  I have not actually installed FreeBSD
on the disk.  I paritioned/labeled the disk with the install
disk, then rebooted the install disk, went into the Fixit
environment and manually mounted ad0x under the various 
/mnt directories.  I then insert the USB drive into the
system that has a full image of FreeBSD from another machine
on it, stored in a tarball, and mount it under /mnt/mnt.
I then start to untar it (to load that image onto my
newly labeled disk), and that's when I see the errors.
The OS running at that time is the FreeBSD 6.3 Fixit

> I just bought a new MSI P4M900M2 mobo.  It works just fine with both
> Windoze and SUSE Linux.  When I tried booting 6.2 on it, it refused to
> set the drive (ad0 - I tried several different drives) into the
> higher speed UDMA modes.  So, I downloaded 6.3, and it *seemed* to
> be fine.  The drives come up as UDMA 100 or UDMA 133.
> But ... under long disk operations - say untaring a 2G tarball
> stored on a USB drive - I start to see this:
> And eventually:
> ad0: FAILURE WRITE_DMA Status=51 .... Error=84
> g_vfs_done():ad0s1f ...
> What's going on here? Is there a known driver problem with the VIA
> chipsets?  I took the two drives I tried this with, and stuck them
> in another machine - no problem, so I kind of doubt this is a drive
> problem.  I have replaced the IDE cables as well.  Again, this same
> mobo and drive combo worked flawlessly doing the same thing under SUSE
> Linux, so I'm thinking this is a software problem.
> Any help much appreciated...

Tim Daneliuk     tundra at tundraware.com
PGP Key:         http://www.tundraware.com/PGP/

More information about the freebsd-questions mailing list