USB printer

Chuck Robey chuckr at
Wed Mar 12 19:44:13 UTC 2008

Hash: SHA1

Manolis Kiagias wrote:
> Chuck Robey wrote:
>> Hash: SHA1
>> Gligor Lucian wrote:
>>> David Kelly <dkelly at> wrote: >On Mon, Mar 10, 2008 at
>>> 12:59:38PM -0700, Gligor Lucian >wrote:
>>>>> Does FreeBSD support a USB printer?
>>>> Yes.
>> You know, while there are printing utils that actually work on FreeBSD, I
>> can't personally recommend CUPS.  I keep on trying to get it to work on
>> FreeBSD efvery year or so, then I need to go over to one of my other
>> systems.  Last one I tried was an Epson Stylus C84, but I've also
>> tried HP
>> officejets, and I just can't get locally attached printers to work with
>> cups.  I can get them to work with things like apsfilter very well, but
>> either someone is going to have to fix the Cups port (it builds, but
>> nothing locally runs) or stop recommending it.
>> Or, does anyone else have it working on FreeBSD?  Sure would like to hear
>> about it, but I've been trying for a long time now, with no success.
>>>     Thank you very much for your answer.
>>>      All the best, Gligor Lucian.
>>>        ---------------------------------
>>> Looking for last minute shopping deals?  Find them fast with Yahoo!
>>> Search.
>>> _______________________________________________
>>> freebsd-questions at mailing list
>>> To unsubscribe, send any mail to
>>> "freebsd-questions-unsubscribe at"
> I have cups working on my system, printing on locally attached USB
> printers.
> I have followed the instructions in dekstopBSD wiki:
> (though I used ports and not packages)
> I still have some issues if I disconnect / reconnect the printer, the
> permissions are not set correctly (although devfs is running).
> I might be missing some configuration step, but have not researched
> further yet.
> Generally speaking, printing works.
OK, well, maybe I'm wrong, I'll go take a look.  As to that other
respondent, the job of doing non-local printers needs much more trivial
drivers, so yeah, that always has worked.  I had looked about on Google,
followed a ton of differing instructions, and hadn't had it come near
working yet.  But, I will go take another look at this URL, yes.
Version: GnuPG v2.0.4 (FreeBSD)
Comment: Using GnuPG with Mozilla -


More information about the freebsd-questions mailing list