portupgrade can't fetch packages

Colin Brace cb at lim.nl
Mon Mar 10 14:38:19 UTC 2008

Hi all,

Earlier today I ran "portupgrade -aP" to update my system. Alas,
everytime it tried to download a package, it failed and resorted to
downloading and compiling the source. For example:

--->  Checking for the latest package of 'lang/python25'
--->  Fetching the package(s) for 'python25-2.5.2_1' (lang/python25)
--->  Fetching python25-2.5.2_1
fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/i386/packages-7-stable/All/python25-2.5.2_1.tbz:
Can't open data connection
** The command returned a non-zero exit status: 1
** Failed to fetch
fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/i386/packages-7-stable/All/python25-2.5.2_1.tgz:
File unavailable (e.g., file not found, no access)
** The command returned a non-zero exit status: 1
** Failed to fetch
** Failed to fetch python25-2.5.2_1
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! python25-2.5.2_1      (fetch error)
** Could not find the latest version (2.5.2_1)
--->  Using the port instead of a package

However, I could copy and paste the given URL,
 into another terminal window and download it manually with wget, ftp,
fetch, and/or curl (I tested them all).

What could be preventing portupgrade from being able to download the
packages itself?


$ uname -r

  Colin Brace

More information about the freebsd-questions mailing list