apache+mod_ssl-1.3.41+2.8.31 crashing with mod_php5

Chris Maness chris at chrismaness.com
Mon Mar 10 02:16:49 UTC 2008

Mel wrote:
> On Sunday 09 March 2008 23:32:00 Erik Wilson wrote:
>> On Sun, Mar 9, 2008 at 6:26 PM, Chris Maness <chris at chrismaness.com> wrote:
>>> I am having apache core dump after I install php5 with the apache
>>> module.  It runs fine without the module directives that are
>>> automagically added to the http.conf file, but after it is compiled and
>>> installed my main log (var log messages) indicates a core dump.
>> Have you upgraded to the latest version of apache to go with the latest
>> version of php5?  Perhaps you have an older version that isn't binary
>> compatible with the latest compiled php.
> Bogus. Php works with any apache version it supports.
> Chris: juggle order of /usr/local/etc/php/extensions.ini, see archive for 
> discussion as to why this can't be handled normally.
OK, after I was able to get apache to load without crashing, none of my 
php aps worked correctly.  I suppose this had to do with me deleting

extensions.ini and only rebuilding php5 and not its dependencies.  Well, after rebuilding all of the deps, I now have a extensions.ini file again.  I tried re-arranging as suggested in the archive, but this did not solve the problem.  I am only having this issue on my 7.0-R box.  6.3-R seems to be working ok, but I haven't been fooling with it.  I am having the issue on my test box.


More information about the freebsd-questions mailing list