Tried to symlink /etc to another disk, now stuck

Steve Bertrand steve at
Fri Jun 13 02:07:34 UTC 2008

Steve Bertrand wrote:
> Dan Nelson wrote:

> I'm off to try it. I've got a system here with a da device. I'll fsck up 
> /etc/fstab, reboot, and report back with the appropriate mountroot> 
> prompt entry...

# cat /etc/fstab

# Device                Mountpoint      FStype  Options         Dump 
/dev/da0a               /               ufs     rw,noatime      1       1
md                      /tmp            mfs     rw,-s32M,nosuid,noatime 
0       0


..change /etc/fstab to mount root to /dev/ad15a, reboot:


# mountroot>ufs:/dev/da0a {ENTER}

...machine boots up.

To the OP...if you know what your disk type is, you CAN get it to 
continue to mount root at the mountroot prompt.

Furthering that, you can also fsck and mount your other disk mountpoints 
in order to gain access to your editing binaries.

There is no need to use an external resource to boot the machine from if 
you are already aware that the only thing that got fsck'd up is the 
mountpoints in the fstab (or, like in this case, the file was 
unavailable entirely). The disk structure is still the same, and the 
system can see this with manual intervention.

OP: at the mountroot> prompt, try this: ufs:/dev/ad0s1a

and see if you get anywhere.


More information about the freebsd-questions mailing list