Tried to symlink /etc to another disk, now stuck

Dan Nelson dnelson at
Fri Jun 13 01:20:32 UTC 2008

In the last episode (Jun 12), Glenn Gillis said:
> I think I did just about the worst thing I could do to my
> organization's FreeBSD-4.11 email server today:
> I was trying to free up space on the root disk and attempted to copy
> the /etc directory to another disk, /new/etc, then delete and symlink
> the old location to the new:
>   $ sudo cp -Rp /etc /new/etc
>   $ sudo rm -rd /etc/; sudo ln -s /new/etc /etc
> Of course, with the sudoers file in the original /etc directory, the
> first "sudo" command to remove the /etc directory disabled the second
> "sudo" command's ability to run.
> Now, I cannot log in as a privileged user to copy or move /new/etc
> back to /etc. (Because the password files were also in /etc.) I've
> tried booting into Single User mode with "boot -s" at the boot
> prompt, only to receive a "mountroot>" prompt wanting to know where
> to find the root filesystem. I've also tried booting from my
> installation distribution, but can't get out of the installation
> without the machine rebooting.
> To make a long story shorter, is there any hope for getting a
> privileged user account on this machine to move /etc back to where it
> should be?

It may be easiest to boot a live CD (FreeSBIE, or a FreeBSD-7 install
disc 1 should work), mount both of your hard drives from it, and put
/etc back where it belongs that way.

	Dan Nelson
	dnelson at

More information about the freebsd-questions mailing list