Perl error running lint on spamassassin? [NO MORE SPAMASSASSIN!!!]

"Kyrre Nygård" kyrreny at
Tue Feb 5 19:29:21 UTC 2008

Hey Drew!

I learned long time ago to drop SpamAssassin altogether. I got hundreds of spam e-mails a day with SpamAssassin.

But when I switched to a clean Postfix installation with Greylist (port 10023) and 3 different blocklist servers, my spams reduced to 0 a day, or 1-3 at most.

$ cat /usr/local/etc/postfix/

# FreeBSD/i386

mail_owner = postfix
home_mailbox = .maildir/

mydomain =
myhostname =
mynetworks =

myorigin = $mydomain
mydestination = $mydomain, localhost.$mydomain, $myhostname,

smtpd_recipient_restrictions =
 check_policy_service inet:

unknown_local_recipient_reject_code = 450

queue_directory = /var/spool/postfix
command_directory = /usr/local/sbin
daemon_directory = /usr/local/libexec/postfix
sendmail_path = /usr/local/sbin/sendmail
newaliases_path = /usr/local/bin/newaliases
mailq_path = /usr/local/bin/mailq
sample_directory = /usr/local/etc/postfix

Suggestions on improving this configuration file is always appreciated.

Have fun!

All the best,

----- Original Message -----
From: Drew <cotharyus at>
Date: Tuesday, February 5, 2008 8:49 am
Subject: Perl error running lint on spamassassin?
To: questions at

> Hi,
> I know I've been noisy of late, but that should slow down if I 
> ever get
> things working around here again. I've given up on my old server 
> hardware,and put another machine in it's place. Unfortunately, 
> everything but mail is
> working for me on this server. The problem seems to be with 
> spamassassin.When I run spamassassin -D --lint from the command 
> line, everything _seems_
> to check out. However, when I run mailscanner --lint it segfaults:
> root at colossus(/)# mailscanner --lint
> Checking version numbers...
> Version number in MailScanner.conf (4.64.3) is correct.
> Your envelope_sender_header in spam.assassin.prefs.conf is correct.
> Checking for SpamAssassin errors (if you use it)...
> SpamAssassin temp dir = 
> /var/spool/MailScanner/incoming/SpamAssassin-Temp
> zsh: segmentation fault  mailscanner --lint
> I wasn't real sure what was causing this, but running SA lint 
> from mailwatch
> provides a clue, perhaps:
> /libexec/ /usr/local/bin/perl5.8.8: Undefined symbol
> "PL_exit_flags"
> I've removed and reinstalled perl5.8 from ports, double checked 
> everythingwith the perl-after-upgrade script, ensured that I've 
> handled the
> use.perlports thing, etc. After all that failed to solve this, I
> rebuilt and
> reinstalled world. Still no joy. I like to try to solve stuff 
> that looks
> easy like this on my own, but obviously at this point, I've overlooked
> something simple. Anyone care to pass me a clue-bat? Thanks in 
> advance._______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-
> unsubscribe at"

More information about the freebsd-questions mailing list