Perl error running lint on spamassassin?

Drew cotharyus at
Tue Feb 5 00:48:37 UTC 2008

I know I've been noisy of late, but that should slow down if I ever get
things working around here again. I've given up on my old server hardware,
and put another machine in it's place. Unfortunately, everything but mail is
working for me on this server. The problem seems to be with spamassassin.
When I run spamassassin -D --lint from the command line, everything _seems_
to check out. However, when I run mailscanner --lint it segfaults:

root at colossus(/)# mailscanner --lint
Checking version numbers...
Version number in MailScanner.conf (4.64.3) is correct.

Your envelope_sender_header in spam.assassin.prefs.conf is correct.

Checking for SpamAssassin errors (if you use it)...
SpamAssassin temp dir = /var/spool/MailScanner/incoming/SpamAssassin-Temp
zsh: segmentation fault  mailscanner --lint

I wasn't real sure what was causing this, but running SA lint from mailwatch
provides a clue, perhaps:

/libexec/ /usr/local/bin/perl5.8.8: Undefined symbol

I've removed and reinstalled perl5.8 from ports, double checked everything
with the perl-after-upgrade script, ensured that I've handled the
use.perlports thing, etc. After all that failed to solve this, I
rebuilt and
reinstalled world. Still no joy. I like to try to solve stuff that looks
easy like this on my own, but obviously at this point, I've overlooked
something simple. Anyone care to pass me a clue-bat? Thanks in advance.

More information about the freebsd-questions mailing list