accessing a networked printer to a FreeBSD box

dhaneshk k dhaneshkk at
Wed Dec 31 09:46:50 UTC 2008


I am trying to access a printer from our LAN to my FreeBSD Desktop PC

which package I needed to do  that ?   system-config-printer  right  ?

NOTE :I am not trying to attach a new printer to FreeBSD just want to access an already working printer in our LAN

installed   system-config-printer from ports , but whenever I tried
to     do   $system-config-printer    , one blank dialog window blinks
away , the in the tty I am getting this error ..

[bhagat at storm /usr/home/bhagat]$ system-config-printer
Traceback (most recent call last):
  File "/usr/local/share/system-config-printer/", line 5272, in <module>
    main(configure_printer, change_ppd)
  File "/usr/local/share/system-config-printer/", line 5242, in main
    mainwindow = GUI(configure_printer, change_ppd)
  File "/usr/local/share/system-config-printer/", line 333, in __init__
AttributeError: 'gtk.AboutDialog' object has no attribute 'set_program_name'
[bhagat at storm /usr/home/bhagat]$ 

the exact issue ? what I made wrong ,   (I dont think I need CUPS to be
installed as I was not trying to attach a printer to this FreeBSD box) .

I am attaching the file please help me fix the
issue   ( OR I have to install any other package than
system-config-printer ?) 

I thank you all in advance for any hints to fix it out .  struggling to fix this issue for the last couple of days ..

Any hints most Welcome


I tried to install gnome-cups-manager too(from ports )   , but installation failed as follows

gnome-cups-manager.c: In function `event_cb':
gnome-cups-manager.c:79: error: syntax error before "do"
gnome-cups-manager.c:79: error: syntax error before ')' token
gnome-cups-manager.c:79: error: `_g_boolean_var_' undeclared (first use in this function)
gnome-cups-manager.c:79: error: (Each undeclared identifier is reported only once
gnome-cups-manager.c:79: error: for each function it appears in.)
gnome-cups-manager.c:79: error: syntax error before ')' token
gnome-cups-manager.c:74: warning: unused variable `printer'
gnome-cups-manager.c: At top level:
gnome-cups-manager.c:53: warning: 'check_cups' defined but not used
gnome-cups-manager.c:72: warning: 'event_cb' defined but not used
gmake[3]: *** [gnome-cups-manager.o] Error 1
gmake[3]: Leaving directory `/usr/ports/print/gnome-cups-manager/work/gnome-cups-manager-0.31/gnome-cups-manager'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/print/gnome-cups-manager/work/gnome-cups-manager-0.31/gnome-cups-manager'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/print/gnome-cups-manager/work/gnome-cups-manager-0.31'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/print/gnome-cups-manager.
[root at storm /usr/ports/print/gnome-cups-manager]# 

Much more than email – don't miss out on the rest of the Windows Live™.

More information about the freebsd-questions mailing list