strange fsck results

reese at reese at
Sun Dec 28 12:08:26 UTC 2008

I am running VMware Server 2.0 but see the same results with 
VMware Server 1.0.  The virtual machines are copies that I 
made by transferring the vmware files for it from another server. 
As far as I know it did not have any fsck problems on that machine 
but I don't have access to it any more.  I have noticed that there 
are a lot of failures (corrupted files) when moving VMware appliances with the 
use of USB memory sticks so I do test them right on the memory 
stick before I disconnect from the PC.

All the host OSs are Windows XP Professional using IDE ATA drives, current
hardware is an HP dx2450 AMD Phenom. but I saw the same errors on an Acer.

The files systems are:

# Device                Mountpoint      FStype  Options         Dump    Pass#
/dev/ad0s1b             none            swap    sw              0       0
/dev/ad0s1a             /               ufs     rw              1       1
/dev/ad0s1e             /usr            ufs     rw              2       2
/dev/ad0s1d             /var            ufs     rw              2       2
/dev/acd0               /cdrom          cd9660  ro,noauto       0       0

Here is a bit from fsck of /var

hueysan_vm: {10} fsck /var
** /dev/ad0s1d (NO WRITE)
** Last Mounted on /var
** Phase 1 - Check Blocks and Sizes
** Phase 2 - Check Pathnames
** Phase 3 - Check Connectivity
** Phase 4 - Check Reference Counts
UNREF FILE  I=190413  OWNER=root MODE=100644
SIZE=235 MTIME=Dec 27 12:23 2008


I get about a dozen similar UNREF errors.

I am only worried about the errors if they might cause a problem 
with the use of the virtual server as a development server.  I have 
installed and have running apache, mysql, sendmail, samba, 
rsync, etc and they all seem to work fine.  I am planning on 
distributing copies of the virtual server to some others who are 
working on a project with me so I really only need to be 
fairly sure that no hidden gotchas are going to plague 
our efforts.  Having the virtual server setup is a BIG plus 
when collaborating with people who only have Windows 
PCs, before I had a central FreeBSD server for testing 
etc but that is so much slower then have a local development 
server.  Being able to just send off a memory stick with the 
VMserver and instructions is fantastic.

Thanks to all,
Charlie Reese

On 27 Dec 2008 at 11:00, Derek Ragona wrote:

> At 12:37 PM 12/26/2008, reese at wrote:
> >I am running FreeBSD 6.3 as a VMware virtual server and am getting some
> >strange results when I run fsck.  When I run it in multi-user mode I get
> >quite a few UNREF FILE errors but when I switch to single user mode
> >fsck does not find any errors.  Is this something I need to worry about
> >and if it is how might I try to get fsck to repair them?
> >
> >
> >TIA
> >Charlie Reese
> You need to give a bit more information:  Are you running your VM under esx 
> server or workstation?  What is your filesystem layout under freebsd.  What 
> is the underlying server and disks you are running vmware on?
>          -Derek
> -- 
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.

More information about the freebsd-questions mailing list