SMP and ACPI problem ??

Lowell Gilbert freebsd-questions-local at
Sat Dec 27 15:49:11 UTC 2008

"Alain G. Fabry" <alainfabry at> writes (in *extremely* long
lines, which I wrapped for him): 

> To make a long story short....everything worked fine on my system
> (7.0-RELEASE FreeBSD). Last night I was updating stuff on my windoswXP
> guess (under qemu) and performed a clean shutdown.
> This morning, after bringing back up my system it has been unbearably
> slow. Without doing anyting to FreeBSD, it suddenly started working in
> SMP mode -> recognizing my 2 processors. Before, it never did
> this...and looking at the speed it is going now, I'm happy it didn't.
> After googling a bit, I tried to disable ACPI in order to fall back to
> single processor mode, but my system keeps acting up like it never did
> before. Very slow booting and KDM/KDE loading. Once up it's ok until I
> run a portupgrade or such.

That's weird all right.  My first guess would be interrupt problems.
vmstat(8) will show you what is happening on that front.

> 1. What are some suggestions as to make it run 'normal' again?
You need to understand what's going wrong first.  

> 2. Is it possible to make it actually run better in SMP mode?

Your system has an SMP kernel, I presume?  [The GENERIC kernel does,
these days.]

> 3. Can my updates on the Qemu WindowsXP host make my FreeBSD system
> suddenly recognize the 2nd CPU? -> this doesn't make sense to me but
> that's the only thing I worked on last night.

Vanishingly unlikely, but not completely impossible.

> I hope I can get some pointers as to what could have caused this and
> what I can do to get it back to the way it was.

I wouldn't be surprised if it were a hardware problem, which can be
tricky to trace down from the software side.

Lowell Gilbert, embedded/networking software engineer, Boston area

More information about the freebsd-questions mailing list