portmanager looping on libtool on 6.2 -> 6.3 upgrade

Alex Kirk alex at schnarff.com
Sat Dec 20 19:05:09 UTC 2008

Hello All,

I'm in the process of bringing a production web/mail server up to  
FreeBSD 7.0 from 6.2. After practicing the process on a non-production  
box set up in essentially the same manner, I discovered that the only  
major issue to look out for was the fact that I needed to hold back  
the upgrade of Python, since the CMS system running on the box will  
die if it doesn't have Python 2.4 specifically.

So last night, I got the actual OS brought from 6.2 -> 6.3, and then  
looked for a different method of port upgrading than I'd used on the  
development system, since even specifying ports to exclude via  
portmanager's "-ip" option didn't seem to work well when going from  
6.3 -> 7.0. I ran across some articles that told me that I could do  
ports one at a time, confirming upgrades of dependencies, with a  
command such as:

portmanager editors/emacs -l -ui -f

I was able to get some ports, such as bash, upgraded using this  
method. However, I've now reached a point where virtually everything I  
try to upgrade is now failing, because it's dependent on libtool,  
which is stuck in some sort of infinite upgrade loop. Attempting to  
upgrade it manually via the same command line as above (replacing  
"editors/emacs" with "devel/libtool15"), I end up with output like this:

ok to update/rebuild /devel/libtool15 libtool-1.5.26 (yes/no/auto yes  
to all) [y/n/a] [y]?

[lots of trimmed-out building activity, followed by two more times  
asking me if it's OK to update/rebuild libtool]

MGPMrUpdate 0.4.1_9 command: #1 of 14  cd /usr/ports/devel/libtool15  
&& make -V OPTIONS
reverting bsd.port.mk patch -=>cd /usr/ports/Mk; patch -R <  
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
|--- /usr/ports/Mk/bsd.port.mk  Tue Nov  8 01:02:51 2005
|+++ bsd.port.mk        Wed Nov 16 02:16:57 2005
Patching file bsd.port.mk using Plan A...
Hunk #1 failed at 2049.
1 out of 1 hunks failed--saving rejects to bsd.port.mk.rej
rCreateInstalledDbVerifyContentsFile 0.4.1_9 error: "@comment ORIGIN:"  
not found in /var/db/pkg/bsdpan-MIME-tools-5.420/+CONTENTS
                 bsdpan-MIME-tools-5.420 installation is corrupt!
                 recomend running "pkg_delete -f  
bsdpan-MIME-tools-5.420" then manually reinstalling this port
  Port Status Report "forced mode"
00001 ----:libtool-1.5.26                      /devel/libtool15         
skipping libtool-1.5.26 /devel/libtool15 marked IGNORE reason:  
looping, 3rd attempt at make
portmanager 0.4.1_9 INFO: finished with some ports not updated  if  
--log was used see /var/log/portmanager.log

I've tried simply going into /usr/ports/devel/libtool15 and running  
"suod make install clean", and I end up with this output:

===>  Installing for libtool-1.5.26
===>   Generating temporary packing list
===>  Checking if devel/libtool15 already installed
===>   libtool-1.5.26 is already installed
       You may wish to ``make deinstall'' and install this port again
       by ``make reinstall'' to upgrade it properly.
       If you really wish to overwrite the old port of devel/libtool15
       without deleting it first, set the variable "FORCE_PKG_REGISTER"
       in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/devel/libtool15.

I'm very nervous about deinstalling it and reinstalling, or doing a  
forced reinstall, because so much appears to be dependent on libtool,  
and the last thing I want to do is bork a busy production box so bad  
that I have to physically go to the data center and hit up the console  
to fix it (especially since I'm not sure I could get in there over the  
weekend, and I'm flying out of town for the holidays on Monday morning).

Does anyone have any advice on how to get this fixed? The system  
appears to be fully functional in the meantime, so it's not a huge  
rush to get things upgraded, but obviously I'd rather progress sooner  
rather than later.

Alex Kirk

This message was sent using IMP, the Internet Messaging Program.

More information about the freebsd-questions mailing list