Problem configuring X: FreeBSD 6.4, Intel video card, Fujitsu lifebook

Mel fbsd.questions at
Tue Dec 2 04:17:21 PST 2008

On Tuesday 02 December 2008 12:33:52 Niki Kovacs wrote:
> Hi,
> I just installed FreeBSD 6.4 on a Fujitsu lifebook. I'm quite new to
> FreeBSD (see previous post "Introduction"). Some time ago, I had bought
> (and partially read) Michael Urban's "FreeBSD 6 Unleashed". I just
> worked through the initial chapters, and managed installing FreeBSD and
> configuring X just fine. Only I ran into trouble installing a desktop
> environment, since building gnome2-lite failed. I thought before doing
> anything, I'd get a more recent set of FreeBSD install discs, since the
> book includes 6.1, which seems a bit outdated.
> Now I did an install using a set of 6.4 install discs. Everything ran
> fine, except I can't get X to work anymore.
> Configuration:
> # Xorg -configure
> # mv /root/ /etc/X11/xorg.conf
> And then test:
> # startx
> X crashes with the following error message:
> Fatal server error:
> Couldn't find PLL settings for mode!
> I googled about this and found a few results... on the Ubuntu 8.10
> bugtracker. Apparently the 'intel' video driver has some problems with
> my specific Intel video card.
> What now? Try to use the older 'i810' instead of 'intel'? But how would
> I do that? Simply replacing the corresponding "Driver" line in xorg.conf
> doesn't help.

How doesn't it help? Is the driver loaded or not? Any relevant info 
in /var/log/Xorg.0.log?


Problem with today's modular software: they start with the modules
    and never get to the software part.

More information about the freebsd-questions mailing list