Problem configuring X: FreeBSD 6.4, Intel video card, Fujitsu lifebook

Niki Kovacs contact at
Tue Dec 2 03:33:55 PST 2008


I just installed FreeBSD 6.4 on a Fujitsu lifebook. I'm quite new to 
FreeBSD (see previous post "Introduction"). Some time ago, I had bought 
(and partially read) Michael Urban's "FreeBSD 6 Unleashed". I just 
worked through the initial chapters, and managed installing FreeBSD and 
configuring X just fine. Only I ran into trouble installing a desktop 
environment, since building gnome2-lite failed. I thought before doing 
anything, I'd get a more recent set of FreeBSD install discs, since the 
book includes 6.1, which seems a bit outdated.

Now I did an install using a set of 6.4 install discs. Everything ran 
fine, except I can't get X to work anymore.


# Xorg -configure
# mv /root/ /etc/X11/xorg.conf

And then test:

# startx

X crashes with the following error message:

Fatal server error:
Couldn't find PLL settings for mode!

I googled about this and found a few results... on the Ubuntu 8.10 
bugtracker. Apparently the 'intel' video driver has some problems with 
my specific Intel video card.

What now? Try to use the older 'i810' instead of 'intel'? But how would 
I do that? Simply replacing the corresponding "Driver" line in xorg.conf 
doesn't help.

Any suggestions?

Niki Kovacs

More information about the freebsd-questions mailing list