dump/restore don't work, handbook lies

Giorgos Keramidas keramida at ceid.upatras.gr
Sun Aug 31 23:50:54 UTC 2008

On Sun, 31 Aug 2008 17:03:53 -0600, Lloyd M Caldwell <lmc at xmission.com> wrote:
> Hello,
> this all on a 7.0 freebsd system.
> Dump/Restore do NOT work as indicated in the handbook (or man pages). It
> would be better to remove information from the handbook rather then have
> information that doesn't work.
> I needed to increase the size of my freebsd root (/).  I booted, single
> user, attached a large usb freebsd formatted file system to receive the
> backup image.  I ran:
>    dump -0af /mnt/d201gly-0.dump /
> it ran with no complaints and an image was left on the large usb file
> system (d201gly-0.dump).

Did you really run dump on a 'live' filesystem?  The filesystem may be
changing under the feet of dump, while it copies data.  That is bound to
cause trouble later on.

> I then booted off the livefs cdrom, went to the "Fix-it" from livefs.
> I ran fdisk to setup a pc partition for freebsd owning the entire disk.
> I ran disklabel to setup and define the swap and 'a' root partition.
> I ran disklabel to install boot blocks.
> I ran newfs on this new 'a' partition.
> I ran fsck and mount on the new 'a' partition placing it at /mnt/root.
> I turned on the large usb drive, fsck'ed it and mounted it on /mnt/restore.
> I cd into /mnt/root and run:
>    restore -rf /mnt/restore/d201gly-0.dump
> it complains about '/' issues
> it complains about 'expecting YYYYYY got ZZZZZZ'

The manpage of restore says:

     expected next file <inumber>, got <inumber>
             A file that was not listed in the directory showed
             up.  This can occur when using a dump created on an
             active file system.

If this is the error you are seeing, then this is the explanation of
what went wrong too.

More information about the freebsd-questions mailing list