dump/restore don't work, handbook lies

Lloyd M Caldwell lmc at xmission.com
Sun Aug 31 23:20:44 UTC 2008


this all on a 7.0 freebsd system.

Dump/Restore do NOT work as indicated in the handbook (or man pages). It 
would be better to remove information from the handbook rather then have 
information that doesn't work.

I needed to increase the size of my freebsd root (/).  I booted, single 
user, attached a large usb freebsd formatted file system to receive the 
backup image.  I ran:

    dump -0af /mnt/d201gly-0.dump /

it ran with no complaints and an image was left on the large usb file 
system (d201gly-0.dump).

I then booted off the livefs cdrom, went to the "Fix-it" from livefs.

I ran fdisk to setup a pc partition for freebsd owning the entire disk.
I ran disklabel to setup and define the swap and 'a' root partition.
I ran disklabel to install boot blocks.
I ran newfs on this new 'a' partition.
I ran fsck and mount on the new 'a' partition placing it at /mnt/root.
I turned on the large usb drive, fsck'ed it and mounted it on /mnt/restore.
I cd into /mnt/root and run:

    restore -rf /mnt/restore/d201gly-0.dump

it complains about '/' issues
it complains about 'expecting YYYYYY got ZZZZZZ'

after an hour it completes and NO data file were restored.  It did 
recreate the directory structure but NOT A SINGLE FILE came back.  I've 
studied the man pages and have no clue how to rectify this.  after 
re-reading the handbook on backup basics, I'm sure that anyone using 
them will loose everything.  They are simply useless.  take them offline.

This is not something a user can "practice", as most (I) don't have 
duplicate hardware of everything to try dump/restore methods and find 
out they don't work.

what went wrong?  how do i get my system back?

lmc at xmission.com

I've been running freebsd since 2.1 and am beginning to see that unix 
and freebsd are at the end of their life.  they are just tooo arcane for 
day-to-day use, which was why i  used them in the last place.  all the 
gui glue won't fix the broken 'flag' ridden ancient (like me) beast.

this is like the 5th thing that I've followed in the handbook that no 
longer works, takes weeks to figure out why and get done.  things that 
should take minutes take hours, weeks, days, months, years.  we have 
made NO progress in computing environments. it's so discouraging that 
there is zero innovation in an industry that had such high expectations 
and potential.

lmc at xmission.com

More information about the freebsd-questions mailing list