[solved] FreeBSD 7.0 not executing /usr/local/etc/rc.d/ at startup

Marco Beishuizen mbeis at xs4all.nl
Sat Apr 19 15:17:47 UTC 2008

On Sat, 19 Apr 2008 17:40:13 +0300
Manolis Kiagias <sonicy at otenet.gr> wrote:

> Ah!!! It just clicked! You got a lot of _enable="NO"
> This is rather unusual - you usually override something from 
> /etc/defaults/rc.conf with a "YES"
> Your /etc/defaults/rc.conf has missing entries. It probably was not 
> upgraded properly (during the mergemaster phase?)
> For example, /etc/defaults/rc.conf normally has this:
> zfs_enable="NO"         # Set to YES to automatically mount ZFS file
> systems
> but yours doesn't, that's why you had to put it in /etc/rc.conf by
> hand.
> I suggest you try with an /etc/defaults/rc.conf from the installation 
> media (I can send you mine if you wish)

Yes, this was it! I ran mergemaster again and it seems
that no new /etc/defaults/rc.conf was installed. After installing
the new one (and deleting the ="NO"-ones in /etc/rc.conf) everything
started like before.

Thanks a lot for all the help.


I suppose some of the variation between Boston drivers and the rest of
the country is due to the progressive Massachusetts Driver Education
Manual which I happen to have in my top desk drawer.  Some of the Tips
for Better Driving are worth considering, to wit:

	"Directional signals are generally not used except during
vehicle inspection; however, a left-turn signal is appropriate when
making a U-turn on a divided highway."

	"When paying tolls, remember that it is necessary to release the
	quarter a full 3 seconds before passing the basket if you are
	traveling more than 60 MPH."

	"When traveling on a one-way street, stay to the right, so as
not to interfere with oncoming traffic."

More information about the freebsd-questions mailing list