su: not running setuid

James jamesh at
Mon Oct 22 11:53:45 PDT 2007

On Mon, 2007-10-22 at 18:51 +0000, Mayank Jain wrote:

> Hi all,
> I have run chown -R uname:wheel . as root in the / directory. Now it is not 
> allowing me to log in as su.
> Giving the following error
> su
> su: not running setuid
> I have also tried su -l but still same error. Can any body suggest me some 
> solution to this problem.
> uname -a
> FreeBSD 6.2-RC1-p1 FreeBSD 6.2-RC1-p1 #0: Mon Dec  4 
> 09:56:16 UTC 2006     
> root at  i386
> I have also tried following but it didn't allow me to do so.
> chown  root:wheel /usr/bin/su
> chown: /usr/bin/su: Operation not permitted

Well, you've broke that, then.
You have to restore correct owners to everything correctly.

The only thing I can think of is a fresh install, which I seem to recall
doesn't overwrite your home dirs, or /usr/local (can anyone back me up
on this?) and never, ever run a recursive ownership change from / again,
ever. Ever.

I'm not even certain you could manage a buildworld from here. Judging
from the fact tat you're running RC1-p1, I'd guess that you may not even
be familiar with what a buildworld is, is that right?

Why did you do that, incidentally? Whatever result you were trying to
achieve can probably be accomplished once your system is running
correctly, so let's find out what it was.


More information about the freebsd-questions mailing list