Xmodmap (or .xinitrc?) broken after xorg upgrade

Matthias Apitz m.apitz at oclcpica.org
Mon Oct 22 01:39:12 PDT 2007

El día Sunday, October 21, 2007 a las 08:38:33PM -0400, Chris Hill escribió:

> About a week ago, I updated my ports, including xorg. Now xmodmap isn't 
> running from ~/.xinitrc like it used to.
> My .xinitrc is the same as it's been for years, so it includes the lines
> if [ -f $usermodmap ]; then
>     xmodmap $usermodmap
> fi
> After some experimenting, I find that if I run
> $ xmodmap .Xmodmap
> $ xmodmap .Xmodmap
> ...twice, as shown, in an xterm after X gets going - then my .Xmodmap 
> takes effect.
> If I comment out that section of ~/.xinitrc, then I only have to run
> $ xmodmap .Xmodmap
> once in an xterm. I would like not to have to run xmodmap manually at 
> all, but have .xinitrc take care of it, just as it used to be before the 
> upgrade.
> Any ideas? Many thanks in advance.

I'm facing a similiar problem in Xorg 6.9 and KDE 3.5.4: I tried
to set some xmodmap values in my ~/.xinitrc before launching
the KDE desktop, like:

xmodmap -e "keycode 0x73 =  Mode_switch"
xmodmap -e "keycode 0x39 =  n N ntilde Ntilde"
xmodmap -e "keycode 0x1a =  e E eacute Eacute"
xmodmap -e "keycode 0x26 =  a A aacute Aacute"
xmodmap -e "keycode 0x1f =  i I iacute Iacute"
xmodmap -e "keycode 0x1e =  u U uacute Uacute"
xmodmap -e "keycode 0x20 =  o O oacute Oacute"
exec startkde

but when X is up the xmodmap's are not in affect. I have to
set them inside X with a small desktop icon.


Matthias Apitz
e <m.apitz at oclcpica.org> - w http://www.oclcpica.org/ http://www.UnixArea.de/
b http://gurucubano.blogspot.com/

More information about the freebsd-questions mailing list