rpc_lockd and syslogd

mr. phreak nollan at phreaker.net
Sat Oct 13 05:36:57 PDT 2007

Message: 16 Date: Sat, 13 Oct 2007 01:06:26 +0200 From: Mel 
<fbsd.questions at rachie.is-a-geek.net> Subject: Re: rpc_lockd and syslogd 
To: freebsd-questions at freebsd.org Message-ID: 
<200710130106.26923.fbsd.questions at rachie.is-a-geek.net> Content-Type: 
text/plain; charset="iso-8859-1" On Saturday 13 October 2007 00:41:31 
mr. phreak wrote:

> > I have a chicken-egg problem. On my diskless setup the syslogd gives me
> > this error during boot:
> >
> > syslogd: cannot open pid file: operation not supported
> >
> > And I tracked the issue to flock() and enabled rpc_lockd. Still it gives
> > me the same error - because rpc_lockd
> > starts AFTER syslogd does. I've tried fiddling around with REQUIRES and
> > PROVIDES in the rc.d files but I cannot make it work... It gives me the
> > error anyway. (or other errors due to rc.d-hacking)... is there any way
> > to solve this? I'd appreciate some help!
> >
> > when running syslogd when logged in it doesn't give me the error so I
> > guess rpc_lockd *really* is the sollution.

Or the solution is specifying a pid file on a memory disk? I can't think of 
any issues with /var/run being /dev/md*, but there might some. In any case, 
syslogd_flags="-s -P /tmp/syslogd.pid" should work as well. The issue I see 
with that is that /etc/rc.d/syslogd doesn't expose it's pidfile for outside 

-- Mel Since I don't have memorydisks, only nfs-mounts (/tmp and /var) 
the problem still remains. It's really a chicken-egg problem and I can't 
find any new point of view to tackle the issue. The best would be if 
someone successfully have altered the rc.d-scrips for a correct rcorder 
and would like to share it - i.e rpc_lockd BEFORE syslogd. J

More information about the freebsd-questions mailing list