Installing freeBSD on an Intel RAID5 partition

Philip M. Gollucci pgollucci at
Wed Oct 10 13:19:04 PDT 2007

Jerry McAllister wrote:
> On Wed, Oct 10, 2007 at 03:35:54PM +0800, nodje wrote:
>> I couldn't find any answer to the question.The problem is that the installer
>> shows up all the disks instead of proposing to install somewhere on the
>> RAID5 partition, in other words, it just doesn't recognize the RAID5.
>> Is it possible at all to install freeBSD on one of those RAID??
>> I've found out that this is also a problem with the few linux distros I've
>> tried. I've heard it was possible now but I'm a little bit surprised by the
>> slow adoption I must say.
> I had something look similar to that on a Dell 2950.
> It put out lots of lines for each separate drive including a device
> controler name.   But I had to dig through the boot messages carefully
> to find a device name for the raid controller.  But, it was there.  Once
> I found it, things went just fine.  I may have done something manually
> with fdisk or maybe dd to the raid device before getting things to
> be happy.  I don't remember exactly.
> Unfortunately, I had to load Susie 10 Linux on it so I can't look back
> right now.  It also would have been a Dell Perc something, probably 5.
> So, the device name might be different from the Intel.
> But, keep searching.
Strange -- I have PowerEdge 1600 with RAID-5 (3disks) installer worked
just fine.

FreeBSD 6.2-RELEASE-p5 #0: Thu Jun 28 17:57:32 UTC 2007

real memory  = 2147418112 (2047 MB)
avail memory = 2096361472 (1999 MB)
MPTable: <DELL     PE 011B     >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  1
 cpu1 (AP): APIC ID:  0

aacd0: <RAID 5> on aac0
aacd0: 139997MB (286714368 sectors)

Filesystem       Size    Used   Avail Capacity  Mounted on
/dev/aacd0s1a    989M     81M    829M     9%    /
devfs            1.0K    1.0K      0B   100%    /dev
/dev/aacd0s1d    1.9G    140K    1.8G     0%    /tmp
/dev/aacd0s1e    6.8G    1.9G    4.4G    30%    /usr
/dev/aacd0s1g     24G     67M     22G     0%    /usr/home
/dev/aacd0s1f     24G    506M     22G     2%    /var
/dev/aacd0s1h     70G    3.2G     62G     5%    /x1
devfs            1.0K    1.0K      0B   100%    /var/named/dev

This worked out of the box with GENERIC kernel on i386

Kernel config custom snippets:
########## SCSI
device scbus    # SCSI Subsystem
device ahc      # AHA2940 and onboard AIC7xxx devices
device da       # Direct Access (disks)
device cd       # CD
device ses      # SCSI Environmental Services (and SAF-TE)
device aac

Philip M. Gollucci (philip at c:323.219.4708 o:703.749.9295x206
Senior System Admin - Riderway, Inc. /
1024D/EC88A0BF 0DE5 C55C 6BF3 B235 2DAB  B89E 1324 9B4F EC88 A0BF

Work like you don't need the money,
love like you'll never get hurt,
and dance like nobody's watching.

More information about the freebsd-questions mailing list